Please consider a donation to the Higher Intellect project. See https://preterhuman.net/donate.php or the Donate to Higher Intellect page for more info.

Olympus TURBO MO 640MB Problems

From Higher Intellect Wiki
Jump to navigation Jump to search

Problem

I just got a free MO drive from a co-worker. Upon installing it on my turbo-color-station, I get this:

Oct 18 19:05:30 puma mach: OLYMPUS MOS364 Rev 1.02 as sd1 at sc0
target 6 lun 0
Oct 18 19:05:30 puma mach: sd1: UNIT ATTENTION
Oct 18 19:05:30 puma mach:      Disk Label: Test
Oct 18 19:05:30 puma mach:      Disk Capacity 606MB, Device Block 2048
bytes
Oct 18 19:05:30 puma mach: Generic SCSI Device as sg0 at sc0 target 7
lun 7
Oct 18 19:05:30 puma mach: Generic SCSI Device as sg1 at sc0 target 7
lun 7
Oct 18 19:05:30 puma mach: Generic SCSI Device as sg2 at sc0 target 7
lun 7
Oct 18 19:05:30 puma mach: Generic SCSI Device as sg3 at sc0 target 7
lun 7

Termination is enabled, I get this message with or without termination. Fine. When Workspace manager finally loads; it tells me that I need to format the disk. Ok, Hmm that's a no brainer, but it tells me it's damaged, and then it says it can't be initialized and spits the disk out. Ok, here's what the console says:

Oct 18 19:24:45 puma mach: sd1 (6,0): ERROR op:0x1a sd_state:4 scsi
status:0x0
Oct 18 19:24:45 puma mach: sd1 (6,0): sense key:0x5  additional sense
code:0x24
Oct 18 19:24:45 puma mach:     SCSI Block in error = 0 (front porch)

Solution

> Unfortunately, NeXT/OPENSTEP can't handle disks with 1024 and 2048
> Bytes.  You have to use disks with a blocksize of 512 Bytes like one
> of 128MB, 230MB, or 540MB disk types.
>                                        Cheers, P. *8^)

Well it worked. Sorta. I booted into single-user mode and issued this command:

# disk -i -l Work /dev/rsd1a

I booted back into multi-user and it appears to be working.