Please consider a donation to the Higher Intellect project. See https://preterhuman.net/donate.php or the Donate to Higher Intellect page for more info.

Rewiring ATX Power Supply for SGI Indy

From Higher Intellect Wiki
Jump to navigation Jump to search

I bought a used Challenge S machine, which turned out to have a broken power supply. I was told the replacement part was expensive and possibly complex to get, so I set about either fixing or replacing it.

A friend of mine familiar with electronics spent a few hours trying to find the problem, but failed (it was not one of the common problems Google turned up in response to a query about Indy power supplies).

So, here's the information acquired by mailing Nidec / Power General (the manufacturers of the original Indy power supply) and reading a web page from Net Express. Please note that while Nidec / Power General were very helpful in providing me all the information necessary, they no longer manufacture these supplies.

The smaller connector for the SGI runs mainly between the control panel and the mainboard. Only three wires go to the power supply itself, and of those none exactly match the ATX signals. I'll cover them later. The next table is about the larger connector, which is of the same type as the ATX connector.

Color codes for matching leads

ATX color	ATX pins	Function	SGI color	SGI pins
Orange	        1, 2, 11	+3.3V	White	1, 2
Black	        3, 5, 7, 13, 15-17	Ground	Black	11-16, 18-20
Red	        4, 6, 19, 20	+5V	Red	3-8
Purple	        9	+5V aux (always on)	Green	9
Yellow	        10	+12V	Yellow	17
Blue	        12	-12V	Blue	10

Other leads

The connections above can power your SGI, but will not start it. The remaining ATX signals are Power On (Green, pin 14), Power OK (Gray, pin 8) and -5V (White, pin 18). The remaining three SGI signals are all on the second, smaller connector; I suggest cutting these leads close to the power supply itself. They are Logic Inhibit (White/Red, pin 9), Fan Control (Brown, pin 20), and Power Fail (Orange, pin 19). -5V is simply not used in the SGI.

One might think that Power Fail and Power OK are similar, but in fact they operate at opposite ends in time. Power OK is used by PC power supplies to indicate that enough voltage is present for operation; the SGI assumes this to be the case when power is activated. Therefore, my Challenge S always fails two tests in the POST when it gets powered on. Power Fail is used as a 5 ms UPS function; it goes low at most 5 ms after power is lost, and at least 5 ms before the main +5V supply drops to +4.75V. If your power supply lacks this function (as all ATX ones will) you should connect +5V to make it stop complaining, at least.

Fan Control is a three-level control for the speed of the fan. At 0V, the fan spins at low speed; at 3.3V, it should operate at medium speed; and at 5V, it should run at full speed. I connected the fan directly to a floppy connector (it needs 12V) so it always runs at full speed.

Logic Inhibit does the same thing as Power On. However, you'll need an inverter (powered by 5V aux) to get it to work. While I hadn't soldered mine in yet, I connected Power On (Green from the atx supply) to ground (Black) to start it up. Now I use a 4049 inverter, connected to ground, +5v aux, logic inhibit and power on. Remember to connect all inputs to something - they should not be left floating.


See Also