Please consider a donation to the Higher Intellect project. See https://preterhuman.net/donate.php or the Donate to Higher Intellect page for more info.

What's New in Macintosh Finder 8.0

From Higher Intellect Vintage Wiki
Jump to navigation Jump to search

More features for working faster

  • Spring-Loaded Folders pop open so you can store and find files in deeply nested folders
  • Dragged Item Commands dialog box lets you move, copy, or make an alias for an item you've dragged
  • Pop-up windows let you arrange frequently-used windows for quick access
  • Window Collapse controls are easy to find and use
  • Contextual Menus show all the commands that apply to a given icon or window
  • Sticky Menus remain open until you choose a command
  • Move to Trash command moves selected items to the Trash
  • Show Original command locates the original item belonging to a selected alias

New options for menus and views

  • Icons on the desktop or in any window can appear as buttons that open with a single click
  • Finder Preferences command gives you one-stop access to features formerly in several control panels and menus
  • Short Menus option simplifies menus for new users
  • You can set the system font to Chicago or Truth in the Appearance Settings control panel
  • List View Show Columns feature now applies to individual folders
  • List View can show when an item was created

Faster system response with more background tasks and updating

  • PowerPC-native code makes the system response to Finder commands faster than ever
  • Copying files (including multiple simultaneous copy operations), emptying the Trash, and updating windows all happen in the background so you can keep working
  • New Copy status dialog box shows time remaining, bytes transferred and left to transfer, and other valuable information
  • Live scrolling occurs when you drag the scroll box in the Finder
  • You can work while windows update, and a spinning arrow lets you know the window is being updated

More control & better access to enhanced graphic elements

  • The desktop can show single-click buttons or double-click icons
  • List view columns have Sort buttons, with the current Sort column in a darker gray than the others
  • List views have a background column grid
  • View menu includes new choices logically ordered
  • New Arrange submenu appears in the View menu
  • Icons on the desktop stay where you expect them to be
  • Keep Arranged option maintains the icon or button arrangement that you set for a window
  • Label menu is now a submenu in the File menu
  • Information header in Finder folders is simpler
  • Icons and folder contents have 3-dimensional and color accents

Browse the New Features

Appearance Settings Control Panel

Appearance.gif

The Appearance Settings control panel (whose appearance may differ from the illustration) replaces the old Color and WindowShade control panels, offering all the original features plus new ones:

  • You use the popup menu to choose your system font - the original system font Chicago or the new font Truth. The font you choose is used when you restart.
  • You can select the Compatibility Mode checkbox if you notice compatibility problems between the new window styles and windows in older applications.

Window Collapse Control

Collapsecontrol.gif

The window collapse control supplements the WindowShade feature. You use the control to hide or show the window contents. The title bar remains visible.

  • To collapse the window, click the collapse control.
  • To show the window, click the collapse control again.

The WindowShade control panel has been removed, and that functionality has been moved into the Appearance Settings control panel.

Sticky Menus

Stickymenu.gif You can make any regular, pop-up, or hierarchical menu "stick" open so that it's easier to choose commands. To make a menu sticky, click a menu name or item quickly without moving the pointer more than a pixel or two.

Once a menu is stuck open, dragging across the menu bar closes that menu and opens the next one.

Sticky menus close when you choose a command. To close a sticky menu without choosing a command, click anywhere outside the menu (for example, on the menu bar).

Contextual Menu

Contextmenu.gif

The contextual menu displays all the commands that apply to the selected icon, window, or text. If more than one item is selected, the contextual menu displays the commands that apply to everything in the selection. If nothing is selected, the contextual menu displays commands that apply to everything on the desktop or in the window that you click.

To use a contextual menu, follow these instructions:

  • To open a contextual menu for an item, hold down the command key and click on it.
  • To open a contextual menu for several selected items, control-click any item in the selection. (The contextual menu shows commands that apply to all items in the selection.)
  • To choose a command on the menu, click the command.
  • To close the menu, click anywhere outside it.
  • To open a contextual menu for a window, control-click anywhere in the window except on an icon or name.

Contextmenuwindow.gif

The contextual menu in the illustration shows commands that apply to the window.

Copy Status

Copydialog.gif

The copy status dialog box shows information about the current copy process, including estimated time remaining, how many bytes have been copied so far, and the source and destination of copied files.

While copying is going on, you're free to work with applications or to perform other operations - including making other copies. You can also copy from a single source to multiple destinations, or copy multiple items to a single destination: for example, you can copy multiple items all at once from a file server to your local hard disk.

Dragged Item Commands

Dragverb.gif

The Dragged Item Commands dialog box shows all the commands you can perform on the items you just dragged.

You can usually do any of the following:

  • Copy the items to the destination
  • Move the items to the destination
  • Create an alias for the items at the destination

If you drag an alias, you can also copy the original item to the destination.

  • To display the Dragged Item Commands dialog box, hold down the Command and Option keys as you drag and drop items.
  • To perform an action, click a command in the dialog box, then click OK.

View Menu

Arrangemenu.gif

The View menu has a new look and includes new commands. Many of the original commands now appear in submenus appropriate to the chosen view, including the new as Buttons view. Choices you make in the View menu apply to the active window. When no window is chosen, choices apply to the desktop (as shown in the illustration).

Items in the Arrange submenu and View Options dialog box apply to the view that you've chosen. Also see List View Options.

Button View

Openwindowbuttonview.gif

Button View is a new Finder view that lets you see icons in any window or on the desktop as single-clickable buttons. Using Button View, you can customize a window to look like At Ease or Launcher.

To set desktop icons to look and act like buttons, follow these instructions:

  1. Click anywhere on the desktop so that no window is selected.
  2. Open the View menu and choose "as Buttons."

To set the icons in any window to look and act like buttons, follow these instructions:

  1. Click in a window to select it.
  2. Open the View menu and choose "as Buttons."

To manipulate a button, follow these instructions:

  • To move a button, drag it by its title.
  • To select a button, drag over it, starting outside the button (as you might select text).

Also see Keep Arranged for information on maintaining the arrangement of buttons by name, date modified, or several other choices.

List View

Listviewsfull.gif

When the view is set to "as List" in the View menu, the contents of the window appear in columns. You use the List View Options command to choose the columns you want to see, including a new column for an item's creation date.

  • To sort the window's contents, click the button above the column by which you want to sort.

The selected column is a darker shade of gray.

List View Options

Listviewoptions.gif List View Options becomes available when you choose As List in the View menu. New features include a creation date view, and a relative date view that uses words such as "yesterday" and "today" instead of just the full date.

Note: Options in View dialog boxes (Button View Options, Icon View Options, List View Options) apply only to the active window.

To set options for List View, follow these instructions:

  1. Select the window whose view you want to set.
  2. Open the View menu and choose "as List."
  3. Open the View menu again and choose List View Options.
  4. Select the options you want, then click OK.

Keep Arranged Option

Keeparrangedicons.gif

You use the Keep Arranged option to automatically maintain the arrangement of buttons or icons in a window or on the desktop. Items remain arranged even when a window is resized (except when you've chosen the View option "by Grid"). When you add a new item, it appears in its appropriate place. The Keep Arranged option appears in the View Options dialog box, available in the View menu.

To choose a constant arrangement for the icons or buttons in a window, follow these instructions:

  1. Click in the window with which you want to work.
  2. Open the View menu and choose "as Icons" or "as Buttons."
  3. Open the View menu again and choose the View Options command (either Icon View Options or Button View Options).
  4. Click the checkbox next to Keep Arranged to put an X in it.
  5. Open the pop-up menu and choose the arrangement you want to use.
  6. Click OK.

Finder Preferences

Finderpreferenceswindow.gif The Labels control panel and the Views control panel have been incorporated into the Finder Preferences window, available from the Edit menu.

You can also use Finder Preferences to turn on short menus - especially good for new users - and spring-loaded folders, a feature that makes a folder open temporarily when you hold an icon on it for a few seconds.

To open the Finder Preferences window, open the Edit menu and choose Finder Preferences.

Short Menus

Shortmenus.gif You use the "short menus" option in the Finder Preferences window to show only a subset of the commands usually displayed when you open a Finder menu.

Short menus are especially helpful for novice users, but they don't allow keyboard shortcuts.

To set the short menus options, follow these instructions:

  1. Open the Edit menu and choose Finder Preferences.
  2. Click the checkbox next to "Use short menus" to put an X in it.

To use regular menus, click the checkbox to remove the X.

Spring-Loaded Folders

You can make folders open temporarily when you hold an icon over them, making it easier to store Finder items inside deeply nested folders. When you release the button, the item drops into the folder and all folders except the destination folder close.

To turn on spring-loaded folders, follow these instructions:

  1. Open the Edit menu and choose Finder Preferences.
  2. Click the checkbox next to "Spring open folders".;
  3. Drag the control to set how long it takes for a folder to spring open when an icon is held over it.

Pop-up Windows

Popupclosed.gif A pop-up window has a tab in place of the title bar. The bottom of a pop-up window is anchored to the bottom of the desktop.

When you click a pop-up window's tab, the window closes so that only the tab is visible.

When you click the tab again, the window opens.

Popupopen.gif

You drag a pop-up window by its tab to the left or to the right to change its position at the bottom of the desktop. You can turn a pop-up window into a regular window by dragging it upward.

To create a pop-up window, follow these instructions:

  1. Select the window by clicking in it.
  2. Open the View menu and choose "as Popup Window."

Information Header

Folderheaderinfo.gif

The information header of Finder folders is simpler, showing only the number of items and the space available on the enclosing volume.

Where appropriate, status icons continue to appear.

Show Original Command

The Show Original command in the File menu locates the original item to which the selected alias belongs. Show Original was formerly available in the Get Info box of an alias.

You can also use Command-R to find the original belonging to a selected alias.

Move to Trash

Trash.gif The Move to Trash command in the File menu moves selected items to the Trash.

You can also use the keyboard shortcut Command-Delete to move items to the Trash.

See Also